Rechnungsverwalter: Kunde anlegen funktioniert nicht
Benutzer: Password: Registrieren
smithx

Beiträge: 6
Registriert seit: 04.01.2017

Kunde anlegen funktioniert nicht
Geschrieben am 17.01.2017 um 21:08
Ich verwende die Linux-Variante und bekomme beim Start des Programs folgenden Fehler:

find_upt error: java.net.UnknownHostException: lenovo510s: lenovo510s: Der Name oder der Dienst ist nicht bekannt

Dies scheint erstmal keine Auswirkungen zu haben. Jedoch wenn ich versuche einen neuen Kunden mit dem Button "Hinzufügen" anlegen möchte, passiert nichts und folgender Fehler wird angezeigt:

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
at tmrechnungstool.b.b.f.i.getName(Unknown Source)
at com.sun.java.swing.plaf.gtk.GTKStyle.getInsets(GTKStyle.java:316)
at javax.swing.plaf.synth.SynthStyle.installDefaults(SynthStyle.java:913)
at javax.swing.plaf.synth.SynthLookAndFeel.updateStyle(SynthLookAndFeel.java:265)
at javax.swing.plaf.synth.SynthPanelUI.updateStyle(SynthPanelUI.java:117)
at javax.swing.plaf.synth.SynthPanelUI.installDefaults(SynthPanelUI.java:100)
at javax.swing.plaf.basic.BasicPanelUI.installUI(BasicPanelUI.java:56)
at javax.swing.plaf.synth.SynthPanelUI.installUI(SynthPanelUI.java:62)
at javax.swing.JComponent.setUI(JComponent.java:666)
at javax.swing.JPanel.setUI(JPanel.java:153)
at javax.swing.JPanel.updateUI(JPanel.java:126)
at javax.swing.JPanel.(JPanel.java:86)
at javax.swing.JPanel.(JPanel.java:109)
at javax.swing.JPanel.(JPanel.java:117)
at tmrechnungstool.b.b.f.i.(Unknown Source)
at tmrechnungstool.b.b.f.e.(Unknown Source)
at tmrechnungstool.b.b.f.I.i(Unknown Source)
at tmrechnungstool.b.b.f.I.a(Unknown Source)
at tmrechnungstool.b.b.f.an.actionPerformed(Unknown Source)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.plaf.basic.BasicButtonListener.focusLost(BasicButtonListener.java:198)
at java.awt.AWTEventMulticaster.focusLost(AWTEventMulticaster.java:229)
at java.awt.Component.processFocusEvent(Component.java:6425)
at java.awt.Component.processEvent(Component.java:6289)
at java.awt.Container.processEvent(Container.java:2236)
at java.awt.Component.dispatchEventImpl(Component.java:4889)
at java.awt.Container.dispatchEventImpl(Container.java:2294)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:995)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:661)
at java.awt.Component.dispatchEventImpl(Component.java:4760)
at java.awt.Container.dispatchEventImpl(Container.java:2294)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
at java.awt.EventQueue$4.run(EventQueue.java:731)
at java.awt.EventQueue$4.run(EventQueue.java:729)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Weiß jemand Rat?
Gast

Beiträge: 1

Re: Kunde anlegen funktioniert nicht
Geschrieben am 17.01.2017 um 21:36 als Antwort an: Themenverfasser
Hallo,

wann genau passiert der Fehler? Wenn du beim Anlegen eines Kunden auf OK-Button druckst? Hat das früher funktioniert?

Gruß
Alex
smithx

Beiträge: 6
Registriert seit: 04.01.2017

Re: Kunde anlegen funktioniert nicht
Geschrieben am 18.01.2017 um 20:37 als Antwort an: Themenverfasser
Ich bekomm den Fehler, wenn ich in der Kundenmaske auf Hinzufügen klicke, um einen neuen Kunden anzulegen bzw. damit sich die Maske für die Eingabe öffnet.
Administrator

Beiträge: 1015
Registriert seit: 01.07.2013

Re: Kunde anlegen funktioniert nicht
Geschrieben am 29.01.2017 um 17:47 als Antwort an: Themenverfasser
Hallo,

beim Start des Programms wird´s geprüft, ob eine neue Version im Netzt vorhanden ist. Wenn diese Prüfung aus irgendwelchen Gründen fehlschlägt, ist es kein Problem, da diese keine weitere Auswirkung hat. Der Fehler mit dem Einlegen neuer Kunden ist sehr merkwürdig. Gibt es einen Eintrag in der Log-Datei?

Viele Grüße
Administrator
Administrator

Beiträge: 1015
Registriert seit: 01.07.2013

Re: Kunde anlegen funktioniert nicht
Geschrieben am 29.01.2017 um 17:51 als Antwort an: Themenverfasser
Funktionieren denn andere Dialoge im Programm? z.B. unter "Einstellungen -> Allgemein -> Geldkonten -> Hinzufügen"

Viele Grüße
Administrator
smithx

Beiträge: 6
Registriert seit: 04.01.2017

Re: Kunde anlegen funktioniert nicht
Geschrieben am 01.02.2017 um 21:08 als Antwort an: Administrator
Beim Start des Programms kommt lediglich noch folgender Fehler:
ind_upt error: java.net.UnknownHostException: lenovo510s: lenovo510s: Der Name oder der Dienst ist nicht bekannt
--> lenovo510s ist der Name meines Rechners

Ansonsten scheint alles zu gehen. Z. B. Geldkonten hinzufügen klappt ohne Probleme
Den einzigen Log-Eintrag, den ich bekomme, ist eben der angehängte Stacktrace
smithx

Beiträge: 6
Registriert seit: 04.01.2017

Re: Kunde anlegen funktioniert nicht
Geschrieben am 18.02.2017 um 11:59 als Antwort an: Administrator
Den Unknownhost Fehler habe ich inzwischen behoben. Auch eine Anlage des Kunden ist zumindest über eine Rechnung möglich.
Jedoch, wenn ich dann diesen Kunden bearbeiten oder wiederum einen neuen Kunden anlegen möchte, bekomme ich immer wieder den bereits genannten Fehler.

Schade, dass es scheinbar keine Lösung für das Problem gibt, denn ich finde das Programm eigentlich gut und so müsste ich die Software extra auf einem Windows-PC vorhalten, um es zu nutzen. :-(

Schauen Sie sich unsere anderen Produkte an:


Schreiben Sie Ihren eigenen Beitrag
Gast

Beiträge: 0
Dieses Thema ist bereits geschlossen. Keine Kommentare können hinzugefügt werden.
rechnungsverwalter.de - Rechnungen leicht erstellen