Benutzer: Password: Registrieren
marryk

Beiträge: 6
Registriert seit: 18.02.2021

Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 23.04.2021 um 17:52
Hallo erneut, leider wurde mein letzter Beitrag vom 18.02.2021 mit Rückfrage am 1.3. hierzu geschlossen, ohne, dass ich einen Lösungsansatz erhalten habe.

Es bleibt dabei - egal, was ich mache,
*selbst mit der Standard-Vorlage*
schreibt er das PDF mit Helvetica, Helvetica Bold, Times Bold und Times Roman.

Vor dem Update ("virtueller Maschienen-Bug") lief alles gut und er bettete meine Fonts auch ein.
Habe nun diverse Möglichkeiten versucht, auch, das die Fonts betreffende CSS direkt ins html zu schreiben, leider erfolglos.

Was kann ich machen - bzw. was wäre der sicherste Weg, die beiden Fonts einzubetten? Hab es über lokale Namen, den lokalen Pfad, das Kopieren in den Template-Ordner, das umbenennen zu Custom1 usw probiert und verzweifle langsam, da sind nun _einige_ Stunden des Versuchens rein geflossen.

Viele liebe Grüße
und besten Dank vorab!
Jean-Claude
aus München

Beiträge: 199
Registriert seit: 20.05.2018

Re: Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 18.05.2021 um 16:05 als Antwort an: Themenverfasser
Hallo,

mit #CUSTOM1#, #CUSTOM2# und #CUSTOM3# sollte es möglich sein, die externe Schriftarten in *.ttf Format einzubinden.

Geh Mal folgendermaßen vor:

- Ersetze in der Standard-Vorlage den Tag #DEFAULT_FONT_FILE# durch #CUSTOM1#
- Kopiere deine TTF-Datei mit der neuen Schriftart ins Datenverzeichnis "c:\Users\BENUTZER\AppData\Roaming\Rechnungsverwalter\"
- Benenne die kopierte Datei in "CUSTOM1.TTF" um
- Starte Rechnungsverwalter neu

Damit sollte es schon gehen. Probiere es ggf. mit den anderen TTF-Dateien.

Wenn es nicht geht, bitte melde dich nochmal.

Viele Grüße
Jean-Claude
Gast

Beiträge: 1

Re: Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 18.05.2021 um 22:02 als Antwort an: Jean-Claude
Vielen lieben Dank für Deine Antwort, Jean-Claude.

Tatsächlich ändert sich aber nichts an der Ausgabe, es sind weiterhin Helvetica, Helvetica Bold, Times Bold und Times Roman eingebettet, obwohl ich diese Angaben nirgendwo finde.

Im RV zeigt er mir die Schriften noch an, im PDF werden sie dann durch o.g. ersetzt - es ist zum Haare raufen. Als würde bei der PDF-Erstellung ein anderes Stylesheet geladen, das ich allerdings nirgendwo finden kann.

Ich arbeite mit XXvorlage.css, XXvorlage_html.css und XXvorlage.xhtml - und er updated die drei Files auch im RV.
Selbst wenn ich in die xhtml die font-faces in einen style-Tag hereinkopiere, bringt es nichts.

Hast Du (oder jemand sonst) vielleicht noch eine Idee?!

Liebe Grüße!
Jean-Claude
aus München

Beiträge: 199
Registriert seit: 20.05.2018

Re: Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 24.06.2021 um 17:14 als Antwort an: Themenverfasser
Hallo,

bist du sicher, dass deine TTF-Datei deine gewünschte Schriftart enthält? Vielleicht war dieser mit der Programmaktualisierung überschrieben.

Viele Grüße
Jean-Claude
marryk

Beiträge: 6
Registriert seit: 18.02.2021

Re: Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 01.07.2021 um 17:51 als Antwort an: Jean-Claude
Hi, Jean-Claude!

Und danke für Deine erneute Antwort, auch wenn ich sie merkwürdigerweise gerade erst gesehen habe, obwohl ich täglich hier reinschaue.

Ja, ich habe die TTFs neu umgeschrieben.

Und wie schon im ersten Beitrag erwähnt:

>> *selbst mit der Standard-Vorlage*
schreibt er das PDF mit Helvetica, Helvetica Bold, Times Bold und Times Roman. <<

Ich steig da wirklich nicht mehr durch, irgendwas scheint mit der PDF-Engine falsch zu laufen, denn im RV zeigt er mir die Fonts ja an...

Hast Du evtl. noch eine Idee?
(...oder jemand anderes?)

vielen Dank vorab & liebe Grüße!
Jean-Claude
aus München

Beiträge: 199
Registriert seit: 20.05.2018

Re: Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 05.07.2021 um 19:39 als Antwort an: Themenverfasser
Hallo,

wenn du den Button "Rechnung als PDF speichern" drückst, wird im Hintergrund eine HTML-Datei im Datenverzeichnis/temp angelegt. Diese kann überprüft werden.

Viele Grüße
Jean-Claude
marryk

Beiträge: 6
Registriert seit: 18.02.2021

Re: Eigene Schriftart fehlt im PDF nach Update - Nachfrage
Geschrieben am 07.07.2021 um 14:01 als Antwort an: Jean-Claude
Hi und danke nochmal. :)

Der aktuell in der HTML-Datei ausgegebene Pfad ist url(file:///C://Users//XXX//AppData//Roaming//Rechnungsverwalter//CUSTOM1.TTF); - was im Prinzip doch auch richtig ist (?!), nur bettet er den Font eben nicht ins PDF ein...

Ich habe das jetzt soweit überprüft - vor dem Update hatte ich zwei lokale Fonts eingebunden, davor nur einen, diesen damals über die Umbenennung in ARIALUNI.TTF - das habe ich nun gerade auch noch einmal versucht, leider mit dem selben Ergebnis, dass davon im PDF nichts zu sehen ist.
Die (PDF-)HTML-Ausgabe ist aber wie damals, als es noch funktionierte.

Auch die direkten lokalen Pfade interessieren das PDF nicht, weder mit Link ins Font-Verzeichnis noch in ein extra erstelltes.

Ich weiss wirklich nicht mehr weiter, wieder sind 2 Stunden dahin gestrichen - ohne Ergebnis.

Hast Du noch eine Idee oder einen - bei Dir funktionierenden - Weg, lokale Fonts einzubinden?

Vielleicht ist die Info auch wichtig, dass ich hier noch Win7 fahre? Hat sich da beim RV-Update etwas geändert??

Vielen lieben Dank und beste Grüße!

Schauen Sie sich unsere anderen Produkte an:


Schreiben Sie Ihren eigenen Beitrag
Gast

Beiträge: 0
Dieses Thema ist bereits geschlossen. Keine Kommentare können hinzugefügt werden.
rechnungsverwalter.de - Rechnungen leicht erstellen